Why is my PHP old?


This is affecting about 6% of users and this number is decreasing, fortunately. The problem simply means that your hosting environment hasn't yet updated the version of PHP (that runs your site). The last old version that'll give you this error is the now-deprecated PHP 5.2.10 (which was released on 18 June 2009). This, and any older version is not sufficient to run JIG (or WP Real Media Library also known as RML). Us developers think that it's reasonable to require hostings (not you, our customers) to update to at least PHP 5.3 (30 June 2009) which is more than 7 years old. If we were to continue supporting older versions, it would mean we would not be able to take advantage of the new technologies and write faster smarter and more efficient software. It's the same situation that finally brought old Internet Explorer version to an end, developers united to discontinue support for old browsers, which enabled the web to be as you know it today.

  • Sometimes you can choose your PHP version in your cPanel, but it's best to ask for your hosting's support.
  • You might want to aim for PHP 5.6 or PHP 5.3, since PHP 7 is "too new" and many plugins and themes don't support it yet (JIG, RML and WordPress core does).

For more information, check out what the official site of WordPress has to say about this topic:

If your host is unable to update your PHP version, time to find a new one.

If you absolutely must stay with them, you can revert the last stable version of JIG v3.3 and/or RML v2.7.3 that supported old PHP. If you do not have such version at hand, contact JIG support or RML's support then the old version will be dispatched to you. It's not recommended and you should only use old versions temporarily or as a last resort.

This troubleshooting fix was posted in General use on January 11, 2017